+48

iOS Widget shows a warning text instead of data

Javier Regueira Serrano 4 years ago • updated by ExxssTeerapong Ratchatani 2 years ago 70
iOS widget shows the message "Debes abrir My Data Manager después de cambiar la tarjeta SIM para mantener el widget actualizado" (message in spanish that translated means "You should open My Fata Manager after change the SIM card for maintaining the widget updating"), but doesn't show any data or graphic. The app is opened already but appears this message. I have tried to setup again the monthly plan, and I have even uninstalled and installed again the app, but it doesn't fix it.
Thanks in advance for your support
+1
Same problem here. I updated to latest version today (5.3.6). I restarted my phone, but the message still remains. I have swapped my SIM card several times and started the app just like the warning says. But it doesnt work. Great app otherwhise :)
+2
Same problem for me with SIM swap. Not resolved by latest update today.
+1
Same problem here ever updated to latest version.
+1
Here is a suggestion, (for the company)

If the widget doesn't work as a feature then just remove it :-). When it works then add it back to the app and release it.
update 5.3.6 , was not FIX the issue whit the widget , maybe is better to be removed , and when the problem is resolved for A to be added again. . Iphone 6+ , Ios 8.1 .

Thanks

D.Todorov
Hi Everyone,

We have a new version of My Data Manager (v5.3.6) that should fix the widget issue for you.

To fix the widget issue:
1. Be sure you've downloaded the latest version of My Data Manager (v5.3.6)
2. Reboot your device

If this still doesn't work, you may need to first uninstall the widget, then reboot your device, and finally reinstall the widget.

***Definitely let us know if you are still encountering problems after following the steps mentioned above.***

Also, please note that this issue was introduced due to an incompatibility with Apple's recent 8.3 iOS release affecting a small subset of users (the widget works fine on iOS 8.2 or earlier versions). We had a limited amount of time to test the widget running iOS 8.3, however we never encountered the bug prior to the widget going live. We are a very small team, so we really appreciate all your support on this community wiki as we work to fix issues as quickly as we can.
  • dear Dave eriksen.
  • the problem affect all users . for example i use IoS 8.1 , my girlfriend 8.2 , we both have the problem whit the widget . I think u must admit the problem is more serious for what you try to say.
  • This steps are preventing ....
  • and don't fix this problem.

Thanks in advance
by the fan of this app

D.Todorov
I've just uninstalled my data manager, rebooted my iPhone and reinstalled the app. It still gives the message on the widget in the notification centreabout needing to open the app before the widget will function due to SIM change.
Problem is still there even after following the steps mentionned above (on iOS 8.3). This app is great and I'm sure the widget will also be great any time soon ;-)
-1
Issue is still present also for me. I did all steps and not working :-(
+1
Ok - we're seeing that several of you are still experiencing the widget issue on v5.3.6.

We are urgently trying to fix this issue and have started investigating a couple new hypotheses, however, we still haven't identified the specific set of circumstances leading to the failed SIM-card detection (which is responsible for that message appearing in the widget instead of one's actual data-usage).

It would really help us if those of you still experiencing the issue could get in touch with us at feedback.ios.mdm@mobidia.com with details about:
1) What kind of SIM card you are using (Pre-paid, Post-paid, "SIM-only plan" SIM, etc)
2) What carrier / country the SIM belongs to
3) A screenshot of your "about" screen in My Data Manager so that we can get the build info

Lastly, is there anyone here for whom the latest release did in fact fix the widget? (It would help to know whether or not our last set of changes had any impact on the problem.)

We really appreciate your help and patience in regards to the widget still not functioning for many of you.
Just sent you the information requested by email. Hope it helps to figure it out somehow.

Besides the widget issue your app rocks. Please keep it up the good work.

Regards,
Eduardo
absolutely this app is the best choice from all in app store . Thanks for this dedication to bring us such a good product
It's not like the widget is core functionality. Without it the app is still plenty useful.

Thanks for a great app (and I will send in the info you requested as soon as possible).
I'm just sent you information requested by mail and wish the information can help to fix the issue soon. Thanks.
+5
Hi Everyone,

A big thank you to everyone that has written in - your information really helped us figure out how to reproduce the issue in-house (finally), and we are now are working towards a fix that we hope will work for virtually everyone that's been affected.

If all goes well, we'll have an updated version to submit to iTunes by end of day tomorrow (after that, the timing is going to depend on how quickly Apple reviews our app).

We'll keep you posted on our progress - thanks again for your help!
That's great! Thanks. Sorry I didn't email the information but I'm glad you have what you need. Look forward to update.
Hi Everyone,

Just wanted to let you all know that we just submitted our latest fix for the widget issue to iTunes, so we're now waiting on Apple to review our submission and approve it to go live. Thanks again for you help!
You maybe droppped the ball on this widget, but you are surely quickly trying to pick it up again! Thanks for the work you are doing!
Hello support,

still no updates concerning the issue?

Thanks ;)
-1
📢📢📣📣⏰⏰⌚️⌚️
+1
5.4.0 does NOT fix the widget issue for me
+2
Same here, 5.4.0 did not do the trick, rebooted iPhone, removed widget, added my plan again, nothing works
Coen
-1
Wait .,.wait ....wait ..... !!!!!!!
+1
Same here. Did all the above and removed the app and reinstalled. Widget still shows a SIM that was changed. I'll disable the widget for now. Thanks in any case for the attempts!
+1
I'm running iOS 8.4 Beta 3 and just so the developers know. It doesn't work for me either and I have updated. Just thought you should know.
+1
Still got the same issue...it's not fix even after update even rebooted iPhone
Mine works now and I didn't need to reboot or reinstall widget thanks so much.
Hello I updated the app 03/06 , but nothing I served , I restarted the phone, also to try to install the app again, still the same problem with the #widget not work, I have an iPhone 5c #ios 8.3 please alguma reply.


Same here. I updated to latest version today but it still tells me i need to swap my simcard and then open the app. I did that but it didnt work. I reinstalled the app but that didnt work either. Thanx for trying though :)
I had a new sim in my phone when the app updated and it worked so There must be a link with the specific sim that was changed previously.
this fix don't change anything for me again :-(

thanks for trying .
*Bump*....
A response would be nice Mobidia!
  • Sleeping & Waiting .......
I'm having this issue for more than 10 days when I switched my carrier provider
running 8.3 iphone 5S
carrier Movistar (argentina)
uninstalled/reinstalled didn't fix the issue
rebooting device didn't fix the issue
removing widget and readding didn't fix the issue

app version 5.4.0
+1
Hi Everyone,

Sorry for the late reply - we've been working on another fix (submitted to iTunes already). We tried a different approach this time, and got a fixed version of our build out to a number of you that were experiencing the problem. We can confirm that this latest fix has worked for everyone that's used it so far, so we're hoping this will fix it for all of you as well.

This has been quite a challenging bug to pin-point and fix, so we really do appreciate your patience with us on this.

Thanks again for your support!
Hi Dave,
Just downloaded the app, but widget is not working, already tried the uninstall widget - reboot fix, but still doesn't work for me.

Anyway, great app.

Regards
Data manager app doesn't work for me either.
Downloaded latest software ver 5.4.0 yesterday

How about that update?... It's been 2 weeks already..
Just updated to 5.5 - it's working for me
Hard reset before even launching the updated app.
Then launch the app and then added the widget.
Just updated to 5.5 and now works like a charm, great work
Uhuuuuuu it's working! I didn't need even to reboot my cellphone. Thank you guys for the hard work and the attempts to find out and fix the problem! :)
Works for me too and I'm on iOS 9. Thank you!!!!!
work perfectly Great job and thx you
work and for me !!
thanks !!

Yessssssss ......
it's work fine !!!!
Many thanks